シックスコアサーバーでphpバージョンをphp5.6に上げたら(たぶん元はphp5.1だったはず)

「お使いのサーバーの PHP では WordPress に必要な MySQL 拡張を利用できないようです。」

となって、お手上げ\( ̄□ ̄;)/

と、相談を受けました。

php.ini絡みだとろうと想像は、つく。

が、ググっても情報はなく、コンパネを見てもそれらしき設定もない(;・・)ゞウーン

仕方なく近場(?)のエックスサーバーっぽくhtaccessで対処してみる。

php5.5なら動いたけど、php5.6にするとダメ。

なんでやねん(--;)

夜も更けておりまして、とりあえず、php5.5にして仮復旧

Zzz・・o(__*)。。oO(熟睡)

翌日、シックスコアのサポートに電話(´▽`[]ゝ

以下、もらったメールのコピペ

比較的以前からシックスコアをご契約いただいている場合、
サーバー側の「php.ini」ファイルの初期設定が原因で
今回ご連絡いただいたエラーが発生することがございます。

サーバー管理ツール「php.ini設定」から該当のドメインを
選択していただき「php.ini直接編集」より
extension_dir の項目をご確認ください。

そして、extension_dirの行の左端に「;」を付記していただき
問題が解決するかどうか再度お試しくださいますでしょうか。
—————————————–
extension_dir = “/usr/lib/php/modules”

↓ 変更

;extension_dir = “/usr/lib/php/modules”
—————————————–

まぁ、これで解消したんですが、、、”比較的以前からご契約しているお客様”に手間かけさせるなよ!

ってことでw

cap-096